Publishing details

Changelog

llvm-toolchain-14 (1:14.0.6-12ubuntu0.23.04.1) lunar-security; urgency=medium

  * SECURITY UPDATE: canonicalize pass crashed with segmentation fault
    - debian/patches/CVE-2023-29932.patch: Use default attributes for
      intrinsics
    - CVE-2023-29932
  * SECURITY UPDATE: convert-scf-to-spirv Pass crashed with segmentation
    fault
    - debian/patches/CVE-2023-29934.patch: Account for type conversion
      failures in scf-to-spirv
    - CVE-2023-29934
  * SECURITY UPDATE: spirv-lower-abi-attrs crashes with segmentation faults
    - debian/patches/CVE-2023-29939.patch: Fix crash in
      spirv-lower-abi-attributes when the are no SPIR-V env attributes
    - CVE-2023-29939

 -- Nishit Majithia <email address hidden>  Fri, 14 Jul 2023 12:41:27 +0530

Available diffs

Builds

Built packages

Package files