Change log for lcov package in Ubuntu

128 of 28 results
Published in mantic-release
Deleted in mantic-proposed (Reason: Moved to mantic)
lcov (2.0-1) unstable; urgency=medium

  * New upstream release
  * Patches now obsolete/merged:
    - handle-equals-signs.patch
    - fix-undef-behaviour.patch
    - reproducibility2.patch
    - 0001-bin-updateversion.pl-avoid-setting-timestamp-bui.patch
  * Fix by Vagrant Cascadian of embedded tz in timestamps breaking
    reproucibility. Closes: #10354394
  * Standards-Version: 4.6.2
  * Build-Dep on libdatetime-perl, libcapture-tiny-perl

 -- Alastair McKinstry <email address hidden>  Thu, 03 Aug 2023 16:19:48 +0100

Available diffs

Superseded in mantic-release
Published in lunar-release
Published in kinetic-release
Deleted in kinetic-proposed (Reason: Moved to kinetic)
lcov (1.16-1) unstable; urgency=medium

  * New upstream release
    - rebase patches
  * Standards-Version: 4.6.1

 -- Alastair McKinstry <email address hidden>  Mon, 06 Jun 2022 09:19:45 +0100

Available diffs

Superseded in kinetic-release
Deleted in kinetic-proposed (Reason: Moved to kinetic)
lcov (1.15-2) unstable; urgency=medium

  * version.patch: version incorrectly reported. Closes: #1011531
  * Close fixed bug; repository now populated. Closes: #990915
  * Patch from Vagrant Cascadian on reproduciblity. Closes: #990914

 -- Alastair McKinstry <email address hidden>  Wed, 25 May 2022 14:12:59 +0100

Available diffs

Superseded in kinetic-release
Published in jammy-release
Deleted in jammy-proposed (Reason: Moved to jammy)
lcov (1.15-1) unstable; urgency=medium

  * New upstream release. Closes: #998808
  * Standards-Version: 4.6.0
  * Use debhelper-compat 13
  * Add debian/gpb.conf file with DEP-14 branches
  * Archive moved to github; update d/watch file
  * Point Vcs-Git to debian/latest branch

 -- Alastair McKinstry <email address hidden>  Mon, 08 Nov 2021 12:18:27 +0000

Available diffs

Superseded in jammy-release
Obsolete in impish-release
Obsolete in hirsute-release
Obsolete in groovy-release
Published in focal-release
Obsolete in eoan-release
Deleted in eoan-proposed (Reason: moved to release)
lcov (1.14-2) unstable; urgency=medium

  * Add patch for gcc 9 support from  upstream. Closes: #924573
  * Ack upgrade to 1.14. Closes: #924573
  * Use debhelper-compat (=12)
  * Standards-Version: 4.4.0
  * Point the VCS to a real salsa repo. Closes: #848955

 -- Alastair McKinstry <email address hidden>  Sat, 17 Aug 2019 09:29:20 +0100

Available diffs

Superseded in eoan-release
Deleted in eoan-proposed (Reason: moved to release)
lcov (1.14-1) unstable; urgency=medium

  * New Upstream release
  * Standards-Version: 4.3.0
  * Now use debhelper 12

 -- Alastair McKinstry <email address hidden>  Mon, 17 Jun 2019 13:23:54 +0100

Available diffs

Superseded in eoan-release
Obsolete in disco-release
Obsolete in cosmic-release
Deleted in cosmic-proposed (Reason: moved to release)
lcov (1.13-4) unstable; urgency=medium

  * Add support for gcc8.
  * Standards-Version: 4.1.4; no changes required
  * Add VCS on salsa.debian.org

 -- Alastair McKinstry <email address hidden>  Mon, 14 May 2018 09:07:06 +0100

Available diffs

Superseded in cosmic-release
Published in bionic-release
Deleted in bionic-proposed (Reason: moved to release)
lcov (1.13-3) unstable; urgency=medium

  * More changes to use dh for bit-reproducibility

 -- Alastair McKinstry <email address hidden>  Sat, 21 Oct 2017 18:59:32 +0100

Available diffs

Superseded in bionic-release
Obsolete in artful-release
Obsolete in zesty-release
Deleted in zesty-proposed (Reason: moved to release)
lcov (1.13-1) unstable; urgency=medium

  * New upstream release. Thanks Sylvestre Ledru. Closes: #848956
  * Move to debhelper 10
  * Remove obsolet patches

 -- Alastair McKinstry <email address hidden>  Wed, 21 Dec 2016 08:25:40 +0000

Available diffs

Superseded in zesty-release
Obsolete in yakkety-release
Deleted in yakkety-proposed (Reason: moved to release)
lcov (1.12-3) unstable; urgency=medium

  * Standards-Version: 3.9.8. No changes required
  * Further reproducibility: Ensure filenames are handled in LC_ALL=C order
	
 -- Alastair McKinstry <email address hidden>  Sat, 09 Jul 2016 12:25:25 +0100

Available diffs

Superseded in yakkety-release
Published in xenial-release
Superseded in xenial-release
Deleted in xenial-proposed (Reason: moved to release)
lcov (1.12-2) unstable; urgency=medium

  * Patch for reproducibility from Reiner Herrmann. Closes: #803412. 

 -- Alastair McKinstry <email address hidden>  Fri, 30 Oct 2015 01:59:16 +0000

Available diffs

Superseded in xenial-release
Deleted in xenial-proposed (Reason: moved to release)
lcov (1.12-1) unstable; urgency=medium

  * New upstream release.
  * Standards-Version: 3.9.6
  * Add Vcs-Git to debian/control

 -- Alastair McKinstry <email address hidden>  Tue, 20 Oct 2015 17:09:43 +0100

Available diffs

Published in trusty-updates
Published in trusty-security
lcov (1.10-1build1) trusty-security; urgency=medium

  * No change rebuild in the security pocket
 -- Marc Deslauriers <email address hidden>   Thu, 12 Feb 2015 11:05:30 -0500

Available diffs

Superseded in xenial-release
Obsolete in wily-release
Obsolete in vivid-release
Deleted in vivid-proposed (Reason: moved to release)
lcov (1.11-3) unstable; urgency=medium


  * Fix each() behaviour now undefined  with perl5.20. Closes: #761308.
  * Acknowledge bug fixed in previous release: Closes: #607206.

 -- Alastair McKinstry <email address hidden>  Sat, 13 Sep 2014 14:05:50 +0100

Available diffs

Superseded in vivid-release
Obsolete in utopic-release
Superseded in utopic-release
Deleted in utopic-proposed (Reason: moved to release)
lcov (1.11-2) unstable; urgency=medium


  * Fix for fail on virtual destructors. Thanks to  Peter Oberparleiter.
    Closes: #752451.
  * Now use xz compression.

 -- Alastair McKinstry <email address hidden>  Tue, 24 Jun 2014 16:22:33 +0100

Available diffs

Superseded in utopic-release
Deleted in utopic-proposed (Reason: moved to release)
lcov (1.11-1) unstable; urgency=medium


  * New upstream release. Closes: #750192.

 -- Alastair McKinstry <email address hidden>  Sun, 01 Jun 2014 08:37:11 +0100

Available diffs

Superseded in trusty-updates
Superseded in utopic-release
Published in trusty-release
Deleted in trusty-proposed (Reason: moved to release)
lcov (1.10-1) unstable; urgency=low


  [Alastair McKinstry]
  * New upstream release. Closes: #699426.
  * Standards-Version: 3.9.5 
  * DH_COMPAT=9 now.
  * Add watch file.

  [Zack Weinberg]
   * Refresh debian/patches:
     - recursion.patch: Applied upstream (closes: #588322)
     - three-arg-open.patch: Applied upstream.
     - genhtml_missing_file.patch: Fixed differently upstream (closes: #578751)
     - utf8-output.patch: Fixed differently upstream (closes #590562)
     - gcc-compat-4.7.patch: Fixed differently upstream.
     - perl-nocaps.patch: Partially applied upstream.
   * New local patch (handle-equals-signs.patch) for the floods of
         geninfo: Argument "=====" isn't numeric. 
      errors that you can get when processing C++ with exception handlers.  
      Closes: #699565.

 -- Alastair McKinstry <email address hidden>  Sat, 30 Nov 2013 15:51:29 +0000

Available diffs

Superseded in trusty-release
Obsolete in saucy-release
Obsolete in raring-release
Obsolete in quantal-release
lcov (1.9-3) unstable; urgency=low


   * Apply Fedora patches by Daniel Berrange, thanks to Michael Wild:
     - gcc-compat-4.7.patch: Fix compat with gcc 4.7
     - three-arg-open.patch: Replace 2 argument open with 3 argument open
   * DH_COMPAT=8 now. 
   * Check FTBFS now fixed:  Closes: #647138.

 -- Alastair McKinstry <email address hidden>  Mon, 14 May 2012 13:42:56 +0100

Available diffs

Superseded in quantal-release
Published in precise-release
Obsolete in oneiric-release
Obsolete in natty-release
lcov (1.9-2) unstable; urgency=low

  * Patch to change genhtml got overwritten by autogenerated debian-changes
    patch. Fixed. Closes: #5999932. 
 -- Ubuntu Archive Auto-Sync <email address hidden>   Sun,  17 Oct 2010 01:19:59 +0000

Available diffs

Superseded in natty-release
lcov (1.9-1) unstable; urgency=low

  * New upstream release. Closes: #599388, #413834.
  * Standards-Version: 3.9.1
  * Patch from Enrico Zini for genhtml in missing source file case.
    Closes: #578571.
  * Patch from Guillem Jover for UTF-8. Closes: #590562.
  * PERL should be spelt "Perl". Closes: #589753.
  * Add Depends: on ${perl:Depends}, gcc; Recommends: libgd-gd2-perl

Available diffs

Superseded in natty-release
Obsolete in maverick-release
lcov (1.8-1) unstable; urgency=low

  * New upstream release. Closes: #561111.
  * Standards-Version: 3.8.4.
  * Moved to debhelper 7 format , source format 3.0
  * Added Homepage: to debian/control. 
 -- Ubuntu Archive Auto-Sync <email address hidden>   Sun,  09 May 2010 13:53:21 +0100

Available diffs

Superseded in maverick-release
Obsolete in lucid-release
Obsolete in karmic-release
lcov (1.7-1) unstable; urgency=low

  * New upstream release: Closes: #478206. 
   - libtool patch no longer required.
  * Move to Standards-Version: 3.8.1; no changes required.
  * Formatted Description better for web display. Closes: #480325.

 -- Ubuntu Archive Auto-Sync <email address hidden>   Wed,  29 Apr 2009 00:16:20 +0100

Available diffs

Superseded in karmic-release
Obsolete in jaunty-release
Obsolete in intrepid-release
lcov (1.6-1) unstable; urgency=low

  * New upstream version. Closes: #479206, #470072.
     - remove patch 10_gcov_tool, now implemented upstream.
     - remove patch 30_compat_libtool, now implemented upstream.

Superseded in intrepid-release
Obsolete in hardy-release
lcov (1.5-2) unstable; urgency=low

  * Add libtool compatability patch from CVS. Closes: #431397.

 -- Ubuntu Archive Auto-Sync <email address hidden>   Tue,  23 Oct 2007 16:56:14 +0100
Superseded in hardy-release
Obsolete in gutsy-release
Obsolete in feisty-release
lcov (1.5-1) unstable; urgency=low

  * New upstream release.
  * Move to DH_COMPAT=5. No changes required.
  * Move to Standards-Version: 3.7.2. No changes required.

 -- Ubuntu Archive Auto-Sync <email address hidden>   Tue,  07 Nov 2006 02:14:09 +0000
Superseded in feisty-release
Obsolete in edgy-release
Obsolete in dapper-release
Superseded in dapper-release
lcov (1.4-1) unstable; urgency=low


  * New upstream release 1.4. Closes: #293184.
  * Include lcov examples.
  * Add Section: devel to debian/control
  * Moved to Standards-Version: 3.6.2; no changes required.

 -- Alastair McKinstry <email address hidden>  Thu,  4 Aug 2005 21:16:04 +0100
Obsolete in breezy-release
lcov (1.3-4) unstable; urgency=low


  * Fix breakage for geninfo on C++ headers. Closes: #293184.
  * Allow option --gcov-tool to change which gcov we use. Closes: #293180.
  * Work with libtool'd libraries. Closes: #290476. 

 -- Alastair McKinstry <email address hidden>  Sun, 13 Feb 2005 21:24:35 +0000
Obsolete in hoary-release
Obsolete in warty-release
lcov (1.3-3) unstable; urgency=low


  * Depend on dbs, not cdbs: Closes: #253613.

 -- Alastair McKinstry <email address hidden>  Sat, 12 Jun 2004 19:34:00 +0100
128 of 28 results