linux-oem-5.6 5.6.0-1007.7 source package in Ubuntu

Changelog

linux-oem-5.6 (5.6.0-1007.7) focal; urgency=medium

  * v5.6.2 stable update (LP: #1870978)
    - Revert "UBUNTU: SAUCE: bpf: undo incorrect __reg_bound_offset32 handling"
    - bpf: Undo incorrect __reg_bound_offset32 handling
    - USB: serial: option: add support for ASKEY WWHC050
    - USB: serial: option: add BroadMobi BM806U
    - USB: serial: option: add Wistron Neweb D19Q1
    - USB: cdc-acm: restore capability check order
    - USB: serial: io_edgeport: fix slab-out-of-bounds read in
      edge_interrupt_callback
    - usb: musb: fix crash with highmen PIO and usbmon
    - media: flexcop-usb: fix endpoint sanity check
    - media: usbtv: fix control-message timeouts
    - staging: kpc2000: prevent underflow in cpld_reconfigure()
    - staging: rtl8188eu: Add ASUS USB-N10 Nano B1 to device table
    - staging: wlan-ng: fix ODEBUG bug in prism2sta_disconnect_usb
    - staging: wlan-ng: fix use-after-free Read in hfa384x_usbin_callback
    - staging: wfx: add proper "compatible" string
    - staging: wfx: fix init/remove vs IRQ race
    - staging: wfx: annotate nested gc_list vs tx queue locking
    - ahci: Add Intel Comet Lake H RAID PCI ID
    - libfs: fix infoleak in simple_attr_read()
    - media: ov519: add missing endpoint sanity checks
    - media: dib0700: fix rc endpoint lookup
    - media: stv06xx: add missing descriptor sanity checks
    - media: xirlink_cit: add missing descriptor sanity checks
    - media: v4l2-core: fix a use-after-free bug of sd->devnode
    - Linux 5.6.1
    - bpf: update jmp32 test cases to fix range bound deduction
    - mac80211: fix authentication with iwlwifi/mvm
    - serial: sprd: Fix a dereference warning
    - vt: selection, introduce vc_is_sel
    - vt: ioctl, switch VT_IS_IN_USE and VT_BUSY to inlines
    - vt: switch vt_dont_switch to bool
    - vt: vt_ioctl: remove unnecessary console allocation checks
    - vt: vt_ioctl: fix VT_DISALLOCATE freeing in-use virtual console
    - vt: vt_ioctl: fix use-after-free in vt_in_use()
    - platform/x86: pmc_atom: Add Lex 2I385SW to critclk_systems DMI table
    - Linux 5.6.2

  * Revert "nvme_fc: add module to ops template to allow module references"
    (LP: #1869947)
    - SAUCE: Revert "nvme_fc: add module to ops template to allow module
      references"

  * suspend only works once on ThinkPad X1 Carbon gen 7 (LP: #1865570)
    - Revert "UBUNTU: SAUCE: e1000e: Disable s0ix flow for X1 Carbon 7th"
    - SAUCE: e1000e: bump up timeout to wait when ME un-configure ULP mode

 -- Timo Aaltonen <email address hidden>  Mon, 06 Apr 2020 11:43:30 +0300

Upload details

Uploaded by:
Timo Aaltonen
Uploaded to:
Focal
Original maintainer:
Ubuntu Kernel Team
Architectures:
all amd64
Section:
devel
Urgency:
Medium Urgency

See full publishing history Publishing

Series Pocket Published Component Section
Focal release main devel

Builds

Focal: [FULLYBUILT] amd64

Downloads

File Size SHA-256 Checksum
linux-oem-5.6_5.6.0.orig.tar.gz 165.8 MiB a463490123537574cc01dd898c62ca8f320579cb8d67447b5e63318e6620bb4a
linux-oem-5.6_5.6.0-1007.7.diff.gz 2.5 MiB 16f873b51f9faca767966217004ec233019210a4385f72f284eabb454183ed07
linux-oem-5.6_5.6.0-1007.7.dsc 4.2 KiB 13b5232f0f93afec57b1f10fdbf5f3714c51005a4cbb0c42a403812586a834ee

View changes file

Binary packages built by this source

linux-buildinfo-5.6.0-1007-oem: No summary available for linux-buildinfo-5.6.0-1007-oem in ubuntu groovy.

No description available for linux-buildinfo-5.6.0-1007-oem in ubuntu groovy.

linux-headers-5.6.0-1007-oem: Linux kernel headers for version 5.6.0 on 64 bit x86 SMP

 This package provides kernel header files for version 5.6.0 on
 64 bit x86 SMP.
 .
 This is for sites that want the latest kernel headers. Please read
 /usr/share/doc/linux-headers-5.6.0-1007/debian.README.gz for details.

linux-image-unsigned-5.6.0-1007-oem: Linux kernel image for version 5.6.0 on 64 bit x86 SMP

 This package contains the unsigned Linux kernel image for version 5.6.0 on
 64 bit x86 SMP.
 .
 Supports OEM processors.
 .
 Geared toward desktop systems.
 .
 You likely do not want to install this package directly. Instead, install
 the linux-oem meta-package, which will ensure that upgrades work
 correctly, and that supporting packages are also installed.

linux-image-unsigned-5.6.0-1007-oem-dbgsym: Linux kernel debug image for version 5.6.0 on 64 bit x86 SMP

 This package provides the unsigned kernel debug image for version 5.6.0 on
 64 bit x86 SMP.
 .
 This is for sites that wish to debug the kernel.
 .
 The kernel image contained in this package is NOT meant to boot from. It
 is uncompressed, and unstripped. This package also includes the
 unstripped modules.

linux-modules-5.6.0-1007-oem: Linux kernel extra modules for version 5.6.0 on 64 bit x86 SMP

 Contains the corresponding System.map file, the modules built by the
 packager, and scripts that try to ensure that the system is not left in an
 unbootable state after an update.
 .
 Supports OEM processors.
 .
 Geared toward desktop systems.
 .
 You likely do not want to install this package directly. Instead, install
 the linux-oem meta-package, which will ensure that upgrades work
 correctly, and that supporting packages are also installed.

linux-oem-5.6-headers-5.6.0-1007: Header files related to Linux kernel version 5.6.0

 This package provides kernel header files for version 5.6.0, for sites
 that want the latest kernel headers. Please read
 /usr/share/doc/linux-oem-5.6-headers-5.6.0-1007/debian.README.gz for details

linux-oem-5.6-tools-5.6.0-1007: Linux kernel version specific tools for version 5.6.0-1007

 This package provides the architecture dependant parts for kernel
 version locked tools (such as perf and x86_energy_perf_policy) for
 version 5.6.0-1007 on
 64 bit x86.
 You probably want to install linux-tools-5.6.0-1007-<flavour>.

linux-oem-5.6-tools-common: Linux kernel version specific tools for version 5.6.0

 This package provides the architecture independent parts for kernel
 version locked tools (such as perf and x86_energy_perf_policy) for
 version PGKVER.

linux-oem-5.6-tools-host: No summary available for linux-oem-5.6-tools-host in ubuntu groovy.

No description available for linux-oem-5.6-tools-host in ubuntu groovy.

linux-tools-5.6.0-1007-oem: No summary available for linux-tools-5.6.0-1007-oem in ubuntu groovy.

No description available for linux-tools-5.6.0-1007-oem in ubuntu groovy.