Change log for llvm-toolchain-14 package in Ubuntu

132 of 32 results
Published in mantic-release
Deleted in mantic-proposed (Reason: Moved to mantic)
llvm-toolchain-14 (1:14.0.6-16) unstable; urgency=medium

  [ Sylvestre Ledru ]
  * also apply the wasm build fix

 -- Gianfranco Costamagna <email address hidden>  Fri, 08 Sep 2023 00:41:35 +0200

Available diffs

Superseded in mantic-release
Deleted in mantic-proposed (Reason: Moved to mantic)
llvm-toolchain-14 (1:14.0.6-13) unstable; urgency=medium

  [ John Paul Adrian Glaubitz ]
  * Don't run chrpath for libclang on powerpc and powerpcspe

  [ Gianfranco Costamagna ]
  * Fix build with newer cmake and gcc-13 (Closes: #1037759)

  [ Nishit Majithia ]
  * SECURITY UPDATE: canonicalize pass crashed with segmentation fault
    - debian/patches/CVE-2023-29932.patch: Use default attributes for
      intrinsics
    - CVE-2023-29932
  * SECURITY UPDATE: convert-scf-to-spirv Pass crashed with segmentation
    fault
    - debian/patches/CVE-2023-29934.patch: Account for type conversion
      failures in scf-to-spirv
    - CVE-2023-29934
  * SECURITY UPDATE: spirv-lower-abi-attrs crashes with segmentation faults
    - debian/patches/CVE-2023-29939.patch: Fix crash in
      spirv-lower-abi-attributes when the are no SPIR-V env attributes
    - CVE-2023-29939

 -- Gianfranco Costamagna <email address hidden>  Mon, 31 Jul 2023 22:10:38 +0200
Superseded in mantic-proposed
llvm-toolchain-14 (1:14.0.6-12ubuntu2) mantic; urgency=medium

  * Fix build with newer cmake and gcc-13

 -- Gianfranco Costamagna <email address hidden>  Mon, 31 Jul 2023 22:10:38 +0200
Superseded in mantic-proposed
llvm-toolchain-14 (1:14.0.6-12ubuntu1) mantic; urgency=medium

  * SECURITY UPDATE: canonicalize pass crashed with segmentation fault
    - debian/patches/CVE-2023-29932.patch: Use default attributes for
      intrinsics
    - CVE-2023-29932
  * SECURITY UPDATE: convert-scf-to-spirv Pass crashed with segmentation
    fault
    - debian/patches/CVE-2023-29934.patch: Account for type conversion
      failures in scf-to-spirv
    - CVE-2023-29934
  * SECURITY UPDATE: spirv-lower-abi-attrs crashes with segmentation faults
    - debian/patches/CVE-2023-29939.patch: Fix crash in
      spirv-lower-abi-attributes when the are no SPIR-V env attributes
    - CVE-2023-29939

 -- Nishit Majithia <email address hidden>  Fri, 14 Jul 2023 12:42:04 +0530
Published in lunar-updates
Published in lunar-security
llvm-toolchain-14 (1:14.0.6-12ubuntu0.23.04.1) lunar-security; urgency=medium

  * SECURITY UPDATE: canonicalize pass crashed with segmentation fault
    - debian/patches/CVE-2023-29932.patch: Use default attributes for
      intrinsics
    - CVE-2023-29932
  * SECURITY UPDATE: convert-scf-to-spirv Pass crashed with segmentation
    fault
    - debian/patches/CVE-2023-29934.patch: Account for type conversion
      failures in scf-to-spirv
    - CVE-2023-29934
  * SECURITY UPDATE: spirv-lower-abi-attrs crashes with segmentation faults
    - debian/patches/CVE-2023-29939.patch: Fix crash in
      spirv-lower-abi-attributes when the are no SPIR-V env attributes
    - CVE-2023-29939

 -- Nishit Majithia <email address hidden>  Fri, 14 Jul 2023 12:41:27 +0530
Published in jammy-updates
Published in jammy-security
llvm-toolchain-14 (1:14.0.0-1ubuntu1.1) jammy-security; urgency=medium

  * SECURITY UPDATE: canonicalize pass crashed with segmentation fault
    - debian/patches/CVE-2023-29932.patch: Use default attributes for
      intrinsics
    - CVE-2023-29932
  * SECURITY UPDATE: convert-scf-to-spirv Pass crashed with segmentation
    fault
    - debian/patches/CVE-2023-29934.patch: Account for type conversion
      failures in scf-to-spirv
    - CVE-2023-29934
  * SECURITY UPDATE: spirv-lower-abi-attrs crashes with segmentation faults
    - debian/patches/CVE-2023-29939.patch: Fix crash in
      spirv-lower-abi-attributes when the are no SPIR-V env attributes
    - CVE-2023-29939

 -- Nishit Majithia <email address hidden>  Fri, 14 Jul 2023 12:39:49 +0530
Superseded in mantic-release
Published in lunar-release
Superseded in lunar-release
Deleted in lunar-proposed (Reason: Moved to lunar)
llvm-toolchain-14 (1:14.0.6-12) unstable; urgency=medium

  [ Samuel Thibault ]
  * Fix hurd build due to missing shared libclang-rt
  * Fix installation conflict between libclang_rt from libclang-rt-14-dev and
    libclang-rt-14-dev-wasm*.

 -- Gianfranco Costamagna <email address hidden>  Fri, 17 Feb 2023 12:57:29 +0100
Superseded in lunar-proposed
llvm-toolchain-14 (1:14.0.6-11) unstable; urgency=medium

  [ Sylvestre Ledru ]
  * Update SV to 4.6.2
  * Disable libc++-$(LLVM_VERSION)-dev-wasm32 on old Debian & Ubuntu:
    bionic buster focal bullseye jammy
    either wasi-libc isn't available or too old or we face bug
    https://sourceware.org/bugzilla/show_bug.cgi?id=27558
  * adjust the lintian override format with the []
  * hardcode a bit less sccache usage

  [ Gianfranco Costamagna ]
  * Fix riscv64 build by adding spirv again (from @paravoid)
  * debian/patches/libclang-cpp-test-link-failure.patch: Cherry-pick
    and change in a minimal way, upstream patch to fix underlinking
    with as-needed default flag (Closes: #1027013)
  * Ignore some wasm32 failures with c++ for now

  [ Samuel Thibault ]
  * Fix hurd build by fixing Linux-specific lines.

 -- Gianfranco Costamagna <email address hidden>  Thu, 16 Feb 2023 10:44:03 +0100
Superseded in lunar-proposed
llvm-toolchain-14 (1:14.0.6-11~build1) lunar; urgency=medium

  * Upload to lunar

 -- Gianfranco Costamagna <email address hidden>  Thu, 16 Feb 2023 10:45:46 +0100
Superseded in lunar-proposed
llvm-toolchain-14 (1:14.0.6-10ubuntu2) lunar; urgency=medium

  * Drop newly-introduced and failing autopkgtest.  Debian bug #1027013.

 -- Steve Langasek <email address hidden>  Thu, 16 Feb 2023 08:39:10 +0000
Superseded in lunar-proposed
llvm-toolchain-14 (1:14.0.6-10ubuntu1) lunar; urgency=medium

  * Fix riscv64 build by adding spirv again (from @paravoid)

 -- Gianfranco Costamagna <email address hidden>  Sat, 07 Jan 2023 21:15:29 +0100
Superseded in lunar-proposed
llvm-toolchain-14 (1:14.0.6-10) unstable; urgency=medium

  * Upload to unstable
  * Add missing epoch (Closes: #1027699)

 -- Sylvestre Ledru <email address hidden>  Sun, 01 Jan 2023 15:42:15 +0100
Superseded in lunar-proposed
llvm-toolchain-14 (1:14.0.6-9build1) lunar; urgency=medium

  * No-change rebuild with Python 3.11 as default

 -- Graham Inggs <email address hidden>  Sun, 25 Dec 2022 20:51:47 +0000
Superseded in lunar-release
Deleted in lunar-proposed (Reason: Moved to lunar)
llvm-toolchain-14 (1:14.0.6-9) unstable; urgency=medium

  * Cherry-pick upstream commit c081bf4098c729afacf20303cc9df62bf13c3362
    to fix chromium failure in basic_string (Closes: #1025394)
  * Disable the MLIR testsuite run because of a freeze
    (Closes: #1024154)
    See https://github.com/llvm/llvm-project/issues/58357
  * Disable wasm on riscv64

 -- Gianfranco Costamagna <email address hidden>  Sun, 04 Dec 2022 09:03:06 +0100
Superseded in lunar-release
Deleted in lunar-proposed (Reason: Moved to lunar)
llvm-toolchain-14 (1:14.0.6-8ubuntu1) lunar; urgency=medium

  * Cherry pick commit e9f28b298ebad01020f5399f520a423fcf2033ea
    (1:14.0.6-9) to fix a test failure on i386
  * Disable wasm on riscv64

 -- Gianfranco Costamagna <email address hidden>  Thu, 24 Nov 2022 14:22:12 +0100
Superseded in lunar-proposed
llvm-toolchain-14 (1:14.0.6-8) unstable; urgency=medium

  * Fix the lldb swig issues (closes: #1023444)
  * Enable LLVM_USE_RELATIVE_PATHS_IN_DEBUG_INFO to help with caching
  * Adjust to protobuf 3.21 (Closes: #1023533)

 -- Sylvestre Ledru <email address hidden>  Fri, 04 Nov 2022 19:36:56 +0100

Available diffs

Superseded in lunar-proposed
llvm-toolchain-14 (1:14.0.6-7) unstable; urgency=medium

  * Disable the cmake search for all binaries
    (cmake_import_check_files_for.*/bin/). Dunno why it regressed
    but we wasted too much time on this.
  * disable sccache on bionic

  [ Jordan Justen ]
  * d/rules: Call bash to use 'command -v' to location llvm-spirv executable
  * d/rules: Set LLVM_SPIRV with cmake for libclc
  * d/patches: Drop libclc-llvm-spirv.diff now that we are setting LLVM_SPIRV
  * d/rules: Check for llvm-spirv with version suffix

 -- Sylvestre Ledru <email address hidden>  Thu, 27 Oct 2022 12:47:19 +0200
Superseded in lunar-release
Published in kinetic-release
Deleted in kinetic-proposed (Reason: Moved to kinetic)
llvm-toolchain-14 (1:14.0.6-2) unstable; urgency=medium

  [ Sam McCall ]
  * Add conventional symlink to libc++ headers in /usr/include/c++/v1
    See https://salsa.debian.org/pkg-llvm-team/llvm-toolchain/-/merge_requests/95
    for more information

 -- Sylvestre Ledru <email address hidden>  Sat, 23 Jul 2022 23:01:02 +0200

Available diffs

Superseded in kinetic-release
Deleted in kinetic-proposed (Reason: Moved to kinetic)
llvm-toolchain-14 (1:14.0.6-1) unstable; urgency=medium

  * New upstream release

 -- Sylvestre Ledru <email address hidden>  Sat, 25 Jun 2022 09:56:23 +0200

Available diffs

Superseded in kinetic-release
Deleted in kinetic-proposed (Reason: Moved to kinetic)
llvm-toolchain-14 (1:14.0.5-1) unstable; urgency=medium

  * New upstream release
  * Only install grpc files libclang-X.Y-dev when grpc built
  * Remove cv-insn-support.patch (applied upstream)

  [ John Paul Adrian Glaubitz ]
  * Disable compiler-rt built-ins on x32

  [ Michael Biebl ]
  * Add support for systemd-binfmt (Closes: #1012368)

 -- Sylvestre Ledru <email address hidden>  Sat, 11 Jun 2022 09:09:03 +0200

Available diffs

Superseded in kinetic-release
Deleted in kinetic-proposed (Reason: Moved to kinetic)
llvm-toolchain-14 (1:14.0.4-4) unstable; urgency=medium

  * autopkgtest: Restrict debian/qualify-clang.sh on
    amd64 arm64 i386

 -- Sylvestre Ledru <email address hidden>  Tue, 31 May 2022 14:08:49 +0200
Superseded in kinetic-proposed
llvm-toolchain-14 (1:14.0.4-2) unstable; urgency=low

  * Merge from Debian unstable. Remaining changes:
  * Add breaks/replaces for grpc binaries being placed in another package in Ubuntu
  * Fix GRPC installation for ports architectures
  * Add support for Ubuntu kinetic
  * rules: take some patches from Ubuntu to save extra space during build

 -- Gianfranco Costamagna <email address hidden>  Sun, 29 May 2022 12:53:47 +0200
Superseded in kinetic-release
Deleted in kinetic-proposed (Reason: Moved to kinetic)
llvm-toolchain-14 (1:14.0.3-2ubuntu1) kinetic; urgency=low

  * Merge from Debian unstable. Remaining changes:
    - Don't build clangd with GRPC support on i386.
    - Fix installation of python3-lldb files.
    - debian/patches/ubuntu-kinetic.patch: Update the list of Ubuntu
      release names.
  * Dropped changes, included in Debian:
    - d/rules: Don't remove libRemoteIndex{ServiceProto,Proto}.a nor
      libMonitoringServiceProto.a.  These are necessary for autopkgtest.
      Adjust d/llvm-X.Y-dev.install accordingly when building on
      i386 (i.e., don't install libRemoteIndex{ServiceProto,Proto}.a in
      such case).
    - Ship libRemoteIndex{ServiceProto,Proto}.a in libclang-14-dev.
      llvm-14-dev.

Superseded in kinetic-release
Deleted in kinetic-proposed (Reason: Moved to kinetic)
llvm-toolchain-14 (1:14.0.0-1ubuntu2) kinetic; urgency=medium

  * debian/patches/ubuntu-kinetic.patch: Update the list of Ubuntu
    release names.

 -- Steve Langasek <email address hidden>  Tue, 03 May 2022 07:14:00 +0000
Superseded in kinetic-release
Published in jammy-release
Deleted in jammy-proposed (Reason: Moved to jammy)
Superseded in jammy-proposed
llvm-toolchain-14 (1:14.0.0-1ubuntu1) jammy; urgency=medium

  * Merge with Debian; remaining changes:
    - Don't build clangd with GRPC support on i386.
    - d/rules: Don't remove libRemoteIndex{ServiceProto,Proto}.a nor
      libMonitoringServiceProto.a.  These are necessary for autopkgtest.
      Adjust d/llvm-X.Y-dev.install accordingly when building on
      i386 (i.e., don't install libRemoteIndex{ServiceProto,Proto}.a in
      such case).
    - Ship libRemoteIndex{ServiceProto,Proto}.a in libclang-14-dev.
      llvm-14-dev.
    - Fix installation of python3-lldb files.

Superseded in jammy-release
Superseded in jammy-release
Deleted in jammy-proposed (Reason: Moved to jammy)
llvm-toolchain-14 (1:14.0.0~+rc4-1ubuntu1) jammy; urgency=medium

  * Merge with Debian, remaining changes:

Superseded in jammy-proposed
llvm-toolchain-14 (1:14.0.0~+rc2-1~exp1ubuntu1) jammy; urgency=medium

  * Merge with Debian; remaining changes:
    - Don't build clangd with GRPC support on i386.
    - d/rules: Don't remove libRemoteIndex{ServiceProto,Proto}.a nor
      libMonitoringServiceProto.a.  These are necessary for autopkgtest.
      Adjust d/llvm-X.Y-dev.install accordingly when building on
      i386 (i.e., don't install libRemoteIndex{ServiceProto,Proto}.a in
      such case).
    - Ship libRemoteIndex{ServiceProto,Proto}.a in libclang-14-dev.
      llvm-14-dev.
  * Fix installation of python3-lldb files.

Superseded in jammy-release
Deleted in jammy-proposed (Reason: Moved to jammy)
llvm-toolchain-14 (1:14.0.0~+rc1-1ubuntu4) jammy; urgency=medium

  * Ship libRemoteIndex{ServiceProto,Proto}.a in libclang-14-dev, not
    llvm-14-dev.

 -- Matthias Klose <email address hidden>  Thu, 17 Feb 2022 06:56:46 +0100
Superseded in jammy-proposed
llvm-toolchain-14 (1:14.0.0~+rc1-1ubuntu3) jammy; urgency=medium

  * Update library names for LLVM 14.

 -- Matthias Klose <email address hidden>  Tue, 15 Feb 2022 06:22:43 +0100
Superseded in jammy-proposed
llvm-toolchain-14 (1:14.0.0~+rc1-1ubuntu2) jammy; urgency=medium

  * Update library names for LLVM 14.

 -- Matthias Klose <email address hidden>  Mon, 14 Feb 2022 13:26:01 +0100
Superseded in jammy-proposed
llvm-toolchain-14 (1:14.0.0~+rc1-1ubuntu1) jammy; urgency=medium

  * Don't build clangd with GRPC support on i386.
  * d/rules: Don't remove libRemoteIndex{ServiceProto,Proto}.a nor
    libMonitoringServiceProto.a.  These are necessary for autopkgtest.
    Adjust d/llvm-X.Y-dev.install accordingly when building on
    i386 (i.e., don't install libRemoteIndex{ServiceProto,Proto}.a in such
    case).
  * d/llvm-X.Y-dev.install.in: Install libs mentioned above.

 -- Matthias Klose <email address hidden>  Fri, 11 Feb 2022 08:00:59 +0100
Superseded in jammy-release
Deleted in jammy-proposed (Reason: Moved to jammy)
llvm-toolchain-14 (1:14.0.0~+rc1-1) unstable; urgency=medium

  * First testing release of 14
  * Upload to unstable
  Changes for 13:
  * mlir: use the cmake option to avoid installing object files
    MLIR_INSTALL_AGGREGATE_OBJECTS
    Closes upstream #53134
  * Build clangd with GRPC support
    Thanks to Sam McCall for the patch
  * Revert e80c52986e1bb3afa6a92c58b1cb897877923a66 to be able to build on stretch

 -- Sylvestre Ledru <email address hidden>  Thu, 10 Feb 2022 09:25:26 +0100
132 of 32 results