Change logs for guile-1.8 source package in Xenial

  • guile-1.8 (1.8.8+1-10ubuntu1) vivid; urgency=medium
    
      * Resynchronise with Debian.  Remaining changes:
        - Build with thread support. Some guile-using programs like autogen need
          it.
        - Add debian/guile-1.8-libs.shlibs: Thread support breaks ABI, bump the
          soname.
    
    guile-1.8 (1.8.8+1-10) unstable; urgency=medium
    
      * Don't declare conflicting flex functions.  Add
        0012-remove-spurious-declarations-in-c-tokenize.lex.patch to fix a
        FTBFS caused by conflicting flex function declarations (yyget_len(),
        etc.).  Thanks to Daniel Schepler <email address hidden> for the
        report.  (Closes: 745969)
    
    guile-1.8 (1.8.8+1-9) unstable; urgency=medium
    
      * Explicitly link against -lpthread on hurd-i386.  This fixes some
        crashes that were caused when Guile dlopened a library that was linked
        against libpthread, which needs to initialize itself much earlier in
        the startup process.  Thanks to Samuel Thibault <email address hidden>
        for the report and the fix. (Closes: #646544)
    
      [ Hideki Yamane ]
      * Fix problems in guile-tut.texi that cause makeinfo to
        fail (partially fixes #711029).
        0008-Fix-problems-in-guile-tut.texi-that-cause-makeinfo-t.patch
    
      [ Dimitri John Ledkov ]
      * Fix r5rs.texi makeinfo failure by applying changes from guile-2.0
        (partially fixes #711029).
        0009-Fix-r5rs.texi-makeinfo-failure-by-applying-changes-f.patch
    
      [ Colin Watson ]
      * Fix test-suite failure caused by formfeed differences in texinfo 5.
        The version of makeinfo in texinfo 5.2 (at least) emits
        slightly-differently-formatted output that breaks
        ice-9/documentation.scm, and hence the test suite.  Later versions of
        Guile implement their own texinfo parsing and thus no longer rely on
        makeinfo for this, but this workaround is enough to fix the test suite
        for now. (Closes: #711029)
        0010-Fix-test-suite-failure-caused-by-formfeed-difference.patch
    
      * Fix incompatibility with automake 1.13; specify serial-tests.  As of
        automake 1.13, the default test harness changed to a newer one that's
        not compatible with Guile 1.8's current arrangement.  Specify
        serial-tests to select the old harness.
        0011-Fix-incompatibility-with-automake-1.13-specify-seria.patch
     -- Colin Watson <email address hidden>   Tue, 11 Nov 2014 15:43:10 +0000